Benutzer-Werkzeuge

Webseiten-Werkzeuge


webedition:tipps:tipp18

Wie kann ich als Entwickler die Code-Qualität von webEdition-Projekten einschätzen?

Jeder Entwickler steht irgendwann vor der Herausforderung Projekte anderer Entwickler zu übernehmen und weiterzuführen. Bei der Übernahme bestehender Projekt ist man dabei mit einigen Unwägbarkeiten konfrontiert … denn man kennt den Code bisher nicht!

Oft kommt der potenzielle Neukunde nicht nur mit dem Projekt, sondern gleich mit einem konkreten Erweiterung- bzw. Wartungsauftrag „um die Ecke“ und wünscht sich schnell eine erst grobe Abschätzung. Hier besteht nun die Gefahr, dass der Entwickler, der das Projekt neu übernimmt, eine kleine Erweiterung bzw. Anpassung sehr gering ansetzt, da diese auch augenscheinlich keinen großen Aufwand verursacht … schließlich wurden gleiche oder ähnliche Anforderungen schon öfter realisiert.

Wie kann man sich nun der Entwickler schnell einen Überblick über die Code-Qualität von webEdition-Projekten verschaffen?

Das geht im Content Management System webEdition glücklicher Weise mit dem Error-Log und dem Rebuild von Vorlagen sehr einfach. Zunächst öffnen wir die Einstellungen über das Menü Extras > Einstellungen > Allgemein und wechseln dan zum Tab Fehlerbehandlung. Dort sollten folgende Einstellungen vorgenommen werden (siehe auch Abbildung 1):

  • Vorlagen: Prüfung auf fehlerhaften Kode (php) deaktivieren –> deaktiviert
  • Fehlerbehandlung: webEdition Fehlerbehandlung aktivieren –> aktivert
  • Zu behandelnde Fehler: alle Checkboxen aktivieren
  • Fehleranzeige: Fehler protokollieren –> aktiviert

Nun werden alle Arten von Fehlern durch das CMS webEdition im Error-Log protokolliert. Bei Live-Systemen, sollte grundsätzlich der Bereich Zu behandelnde Fehler nur für Test alle Checkboxen aktiviert haben, da sonst das Error-Log sehr schnell volllaufen kann und dadurch die Website unter Performance-Problemen zu leiden hat.

Anschließend starten wir nun einen Rebuild aller Vorlagen über das Menü Datei > Rebuild … und wählen dann zunächst Dokumente und Vorlagen klicken dann auf den Button Weiter. Im nächsten Schritt wählen wir dann Alle Vorlage und stoßen den Rebuildvorgang mit dem Button Weiter an.

Nun sollte der Rebuild einmal vollständig durchlaufen. Endet der Rebuild nicht bei 100% ist das ein ersten Zeichen, dass in der Programmierung ein Fehler vorliegt. Ist der Rebuild durchgelaufen oder abgebrochen, öffnen wir nun das Error-Log über das Menü Hilfe > Fehler-Protokoll und können nun alle Einträge auswerten und einen ersten Überblick über das Projekt verschaffen.

webedition/tipps/tipp18.txt · Zuletzt geändert: 2015/12/22 19:48 von Marc Krämer

Recent changes RSS feed